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Problem with myBCIT Session Timeout Error

At the While logged into myBCIT, you receive a session timeout error when accessing various parts of myBCIT.

Error message

myBCIT Session Timeout

Cause

The myBCIT session has not been properly cleared from the cache of the browser.

Recommended method for logging into and out of myBCIT

  • When logging out of myBCIT, always use the Logout button (rather than the X) at the top right of the page.  This allows myBCIT to end your session properly.
  • Do not log into myBCIT more than once at any time.
  • If you are logged into myBCIT in one browser window, log out before logging in at another browser window.
  • When you are using the myBCIT E-mail Center and are finished with it, click on the Log Out link to close the window rather than the X in the upper right corner of the window.

Resolution

Steps are listed below that you can take to resolve the session timeout error.  Start with Section A and if necessary move on to Sections B and C.

  • When asked to close your browser in the instructions below, please note where you are in the instructions so you can return to that spot when you re-open your browser.  Also, note the URL (address) of this web page so you can return to it.

A.  Clear the Cache

B.  Restart your computer
C.  Use another browser

Detailed instructions

Section A. Clear the cache

Clear the cache in Internet Explorer

If you are not concerned with keeping your Internet Explorer cookies, go directly to step 9.  Otherwise, start at step 1.

1.  Open an Internet Explorer browser window. If you have any other Internet Explorer windows open, please close them.
2.  At the top right of the window, Select the Gear Icon
3.  Hover over the Safety section and select Delete Browsing History

    • If you do not see the menu bar, right click the top of the browser and select Menu Bar.

4.  In the Delete Browsing History dialog box, remove all checkmarks but the two shown below.
5.  Click Delete.  
6.  Close Internet Explorer and re-open it to this page.

Delete browsing history page 1.

7.  Ensure you have only one Internet Explorer window open.
8.  Read the bullet points below, then log into myBCIT.  After you log in:

    • If the error is gone, you are finished with these instructions.
    • If the error is not gone, note where you are in these instructions, log out of myBCIT if neccessary using the Logout icon at the top right of the page, then close Internet Explorer and re-open it to this page and carry on with step 6.
    • Log into myBCIT.

9.  Ensure you have only one Internet Explorer window open.
10. At the top right of the window, select the Gear icon.
11. Hover over the Safety section and select Delete Browsing History.

    • If you do not see the menu bar, right click the top of the browser and select Menu Bar.

12. In the Delete Browsing History dialog box, remove all check marks but the three shown below.
13. Click Delete.
14. Close Internet Explorer and re-open it to this page

Delete browing history page 2.

15. Ensure you have only one Internet Explorer window open.
16. Read the bullet points below, then log into myBCIT.  After you log in:

    • If the error is gone, you are finished with these instructions.
    • If the error is not gone, log out of myBCIT using the Logout icon at the top right of the page
    • Close Internet Explorer and re-open it to this page
    • Log into myBCIT.
    • If the error is still not gone, move on to Section B

Clear the cache in Firefox

1.  Open a Firefox browser window. If you have any other Firefox windows open, please close them.
2.  Click the three horizontal lines in the top right corner of your browser window to bring up the Firefox menu.
3.  Click the gear labelled Options.
4.  Navigate to Privacy & Security ->History -> Clear History
5.  In the Clear Recent History box, click the Details down arrow and make sure the cache check mark is selected.
6.  Click Clear Now.
7.  Close and reopen Firefox.

    • Remember to ensure you have only one Firefox window open.

8.  Read the bullet points below, then log into myBCIT.  After you log in:

    • If the error is gone, you are finished with these instructions.
    • If the error is not gone, note where you are in these instructions, log out of myBCIT if necessary using the Logout icon at the top right of the page
    • Close Firefox and re-open it to this page.
    • Log into myBCIT

9.  Select History > Clear Recent History from the menu bar.
10.  Set Time range to clear to Everything.
11.  If necessary, click on the arrow next to Details to expand the list of history items.
12.  Select Cookies and make sure that the other items you want to keep are not selected.
13.  Click Clear Now to clear the cookies.
14.  Close Firefox and re-open it to this page.

    • Again, ensure you have only one Firefox window open.

15.  Log into myBCIT. After you log in:

    • If the error is gone, you are finished with these instructions.
    • If the error is not gone, log out of myBCIT if necessary using the Logout icon at the top right of the page.
    • Go to Section B below.

Clear the cache in Google Chrome

1.  Open Google Chrome and ensure that you only have one Chrome browser window open.
2.  Click the three vertical dots in the top right corner of your browser window to bring up the menu.
3.  From this menu, hover the mouse over the history button, then select History from the pop-out menu.
4.  From the history page, click the three horizontal lines in the top left corner of your window and click clear browsing data from the pop-out menu.
5.  In the Clear browsing data window, make sure to have the cached images and files and cookies and other data check boxes selected.
6.  Close Google Chrome then re-open it to this page.

    • Ensure that you only have one Google Chrome window open

7.  Read the following bullet points below, then log into myBCIT. After you log in:

    • If the error is gone, you are finished with these instructions.
    • If the error is not gone, note where you are in these instructions, log out of myBCIT if necessary using the Logout icon at the top right of the page, then close Firefox and re-open it.
    • Log into myBCIT.

Clear the cache in Microsoft Edge

1.  Open Microsoft Edge, ensure that you only have one Microsoft Edge window open
2.  Click the three dots in the top-right corner of the browser window to bring up the menu.
3.  From the menu, select Settings Clear browsing data, choose what to clear
4.  In the clear browsing data menu, ensure to have at least the cached data and files and the Cookies and Saved website data checkboxes selected.
5.  Click Clear.

    • Make a note of where you are in these instructions and close Microsoft edge and re-open to this page.
    • Ensure that you have only one Microsoft Edge window open

6.  Log into myBCIT. After you log in:

    • If the error is gone, you are finished with these instructions.
    • If the error is not gone, log out of myBCIT using the Logout icon at the top right of the page
    • Close the Edge browser and re-open it.
    • Log into myBCIT
    • If the error is still not gone, move to Section B below.

Section B. Restart your computer

Restarting your computer forces Windows to release all sorts of resources. Save your work, close applications you have running, and reboot.

Section C. Use another browser

If none of the above solutions work, please try using a different web browser.

More information

If the session timeout error is still a problem after trying the above resolutions, please contact the Service Desk via chat, by phone at 604-412-7444 (option 1), or by e-mail.