While logged into myBCIT, you receive a session timeout error when accessing various parts of myBCIT.
Error message
myBCIT Session Timeout
Cause
The myBCIT session has not been properly cleared from the cache of the browser.
Recommended method for logging into and out of myBCIT
- When logging out of myBCIT, always use the Logout button (rather than the X) at the top right of the page. This allows myBCIT to end your session properly.
- Do not log into myBCIT more than once at any time.
- If you are logged into myBCIT in one browser window, log out before logging in at another browser window.
- When you are using the myBCIT E-mail Center and are finished with it, click on the Log Out link to close the window rather than the X in the upper right corner of the window.
Resolution
Steps are listed below that you can take to resolve the session timeout error. Start with Section A and if necessary move on to Section B.
- When asked to close your browser in the instructions below, please note where you are in the instructions so you can return to that spot when you re-open your browser. Also, note the URL (address) of this web page so you can return to it.
A. Clear the Cache
B. Use another browser
A. Clear the cache
B. Use another browser
If none of the above solutions work, please try using a different web browser.
More information
If the session timeout error is still a problem after trying the above resolutions, please contact the ITS Service Desk.
More resources for using myBCIT
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About myBCIT, Online Self Service, and myBCIT Email for Students
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Frequently Asked Questions about Inactive email accounts on my.bcit.ca
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Frequently Asked Questions about the Employee Dashboard in myBCIT
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myBCIT Announcement Guidelines and Frequently Asked Questions
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Printing your Tuition Tax Receipt T2202 in myBCIT Online Self Service
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Retrieving/Resetting Lost or Forgotten BCIT Login Credentials
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Updating your Contact Information in myBCIT Online Self Service
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Viewing and Ordering Transcripts in myBCIT Online Self Service