Issue
When launching the non-installation version of the ShareLink application (e.g. SL_Lite_v3.0.0.4_.10.96.###.###.exe), you are prompted with a Windows Security dialog stating “This setting is managed by your organization”. The option to allow is greyed out and you would like to allow application to access the network.
Security Message
Cause
The application requires network access to operate and there is no firewall rule in place permitting this access while connected to the BCIT network. The non-installation version of ShareLink is a self-extracting package. Since the application is not installed, it extracts itself into a random temporary folder each time. This random path cannot be pre-determined for proper firewall rule creation.
Resolution
To resolve this issue, install the ShareLink application from Company Portal. This installed version will automatically create the correct firewall rule on your device.
- Launch “Company Portal” from the Desktop or Start Menu
- Select Apps on the left hand side
- Find and select “ShareLink”
- Select Install
For more information on installing BCIT software via Company Portal, please review article: Installing BCIT software on BCIT computers
More information about software licensing at BCIT
-
Expiry, Access, and Migration Dates for Adobe Creative Cloud Subscriptions
-
Frequently Asked Questions About BCIT-Issued Laptops for Faculty and Staff
-
Installing Adobe Software on your BCIT-issued or Personal Device for BCIT Employees
-
Known Issue: Change of Email Address Will Disrupt a BCIT Adobe subscription
-
Migrating your Adobe Assets out of Adobe Creative Cloud before your Subscription ends
-
Options for creating a Windows environment on your Mac computer to run apps with AppsAnywhere
-
Problem Installing Adobe Software – “You don’t have access to manage apps”
-
Problem with Windows Security pop-up when launching Application
-
Problem with Windows Security pop-up when launching ShareLink Application
-
Requesting Camtasia/Snagit/TechSmith Software Licenses (Faculty and Staff Only)
-
Software Installed on BCIT-issued Windows Devices for Employees
-
Testing AppsAnywhere Software in BCIT Computer Labs Remotely