Issue
When launching an application, you are prompted with a Windows Security dialog stating Windows Firewall blocked some features and that this setting is managed by your organization. The option to allow is greyed out and you would like to allow application to access the network.
Cause
The application requires network access to operate and there is no firewall rule in place permitting this access while connected to the BCIT network. Not all applications create a firewall rule automatically during its installation.
Resolution
Depending on the application you will need to manually modify a firewall rule the application has created or create a new one.
To verify/modify a firewall rule:
- Select Cancel on the Windows Security dialog.
- Launch Windows Defender Firewall with Advanced Security (C:\Windows\system32\WF.msc)
- Find all the entries for the application by “Name” or “Program” columns – if no entries exist, you will have to manually create the Windows Firewall rule. See Create Firewall Rule below.
- e.g. Android Studio – adb.exe
- Double click each entry to edit its properties.
- Select the General tab.
- Select “Allow the connection”
- Select the Advanced tab.
- Check “Domain” to allow while connected to the BCIT network (includes myVPN)
- (Optional) Check Private to allow while connected to a network classified as “Private”
- (Optional) Check Public to allow while connected to any other network
- Select OK to save changes.
To create a new firewall rule:
- Select Cancel on the Windows Security dialog.
- Launch Windows Defender Firewall with Advanced Security (C:\Windows\system32\WF.msc)
- Right click on “Inbound Rules” and select “New Rule…”
- Select ‘Program’
- Select “Browse” under ‘This program path:’
- Locate and select the application executable in the file browser you want to allow.
- Select “Open”
- Select “Next”
- Select “Allow the connection”
- Select “Next”
- Ensure “Domain” is checked. Optionally check “Private” and/or “Public” if required.
- Select “Next”
- Type in a descriptive name for the rule e.g. Android Studio
- Select “Finish”
More information about software licensing at BCIT
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Expiry, Access, and Migration Dates for Adobe Creative Cloud Subscriptions
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Frequently Asked Questions About BCIT-Issued Laptops for Faculty and Staff
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Installing Adobe Software on your BCIT-issued or Personal Device for BCIT Employees
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Known Issue: Change of Email Address Will Disrupt a BCIT Adobe subscription
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Migrating your Adobe Assets out of Adobe Creative Cloud before your Subscription ends
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Options for creating a Windows environment on your Mac computer to run apps with AppsAnywhere
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Problem Installing Adobe Software – “You don’t have access to manage apps”
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Problem with Windows Security pop-up when launching Application
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Problem with Windows Security pop-up when launching ShareLink Application
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Requesting Camtasia/Snagit/TechSmith Software Licenses (Faculty and Staff Only)
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Software Installed on BCIT-issued Windows Devices for Employees
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Testing AppsAnywhere Software in BCIT Computer Labs Remotely