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Contributing to the Knowledge Base

If you have information on how to use any IT supported BCIT technology or navigate any BCIT system managed by ITS (whether technological or social) for faculty, staff, or students, we want to help you make it accessible through the Knowledge Base.

Please use one of the layout guides below when you write your article. These guides offer guidance on the information needed and basic structure. Once you’ve written the article, email the file (one article per email), to kb@bcit.ca. All that is required is a knowledge of Microsoft Word or basic HTML and the knowledge you want to share in the article itself. Once your article is published in the Knowledge Base, you will receive periodic reminders to review the article to make sure it is still current and accurate. All submissions will be edited lightly and, where possible tested, in order to ensure accuracy, completeness, and consistency in tone and language use. If writing isn’t your forte, but knowledge is, we can also provide a more robust level of editing/writing support.

NOTE: The content owner for all articles must be an employee who works in IT Services. If the article cannot be supported by an IT Services employee, the knowledge base may not be the best location for this information.

There is a layout guide for each article type. Layout guides are provided in both Word and in HTML. You can use either when creating your article. “How to”-type articles are the most common, however strict adherence to form is not required.

Word

If you are not familiar with the basics of HTML, you can use the Word layout guides below to create your content. Be sure to fill out the data table at the top of the form before submitting your article.

Overview/Backgrounder [docx]

Category:

(What general grouping does the article fit in?)

Audience:

(Choose 1: Students, Faculty & Staff, or ITS only)

Keywords:

(Alternate words that might be searched to reach this article, list should be comma separated.)

Synopsis:

(One sentence describing content of article.)

Review Cycle:
(1-12 months, or a set of specific dates for review yearly)
Content Owner:
(Primary contact, able to review the article on the review cycle.)
Subject Matter Expert:
(Alternate contact, able to review if content owner is not available.)

Article title (capitalized as though it were a sentence, not in title case)

Introductory paragraph. Provide a high-level description of the subject being covered. Be sure to let the reader know what they will know when they’re finished reading.

Descriptive heading to emphasize important points and to split content up into readable chunks (capitalized as though it were a sentence, not in title case)

More background information.

More information

Paragraph explaining where more information may be found (with links), or

  • Bulleted list of related articles (including URLs, if possible), and
  • Other resources

Quick Reference [docx]

Category:

(What general grouping does the article fit in?)

Audience:

(Choose 1: Students, Faculty & Staff, or ITS only)

Keywords:

(Alternate words that might be searched to reach this article, list should be comma separated.)

Synopsis:

(One sentence describing content of article.)

Review Cycle:
(1-12 months, or a set of specific dates for review yearly)
Content Owner:
(Primary contact, able to review the article on the review cycle.)
Subject Matter Expert:
(Alternate contact, able to review if content owner is not available.)

Article title (capitalized as though it were a sentence, not in title case)

Introductory paragraph.

Column 1 title Column 2 title Column 3 title
Row 1 main topic Procedural lead in:

·        First step.

·        Second step.

Further details.
Row 2 main topic Procedural lead in:

·        First step.

·        Second step.

Further details.
Etc.

More information

Paragraph explaining where more information may be found (with links), or

  • Bulleted list of related articles (including URLs, if possible), and
  • Other resources

How To [docx]

Category:

(What general grouping does the article fit in?)

Audience:

(Choose 1: Students, Faculty & Staff, or ITS only)

Keywords:

(Alternate words that might be searched to reach this article, list should be comma separated.)

Synopsis:

(One sentence describing content of article.)

Review Cycle:
(1-12 months, or a set of specific dates for review yearly)
Content Owner:
(Primary contact, able to review the article on the review cycle.)
Subject Matter Expert:
(Alternate contact, able to review if content owner is not available.)

Article title (capitalized as though it were a sentence, not in title case)

Introductory paragraph.

Procedure title (capitalized as though it were a sentence, not in title case)

  1. Step 1.
    [screen capture illustrating step 1]
  2. Step 2.
  • Explanatory note.

Alternate or accessory procedure title

  1. Step 1.
    [screen capture illustrating step 1]

More information

Paragraph explaining where more information may be found (with links), or

  • Bulleted list of related articles (including URLs, if possible), and
  • Other resources

Known Problem [docx]

Category:

(What general grouping does the article fit in?)

Audience:

(Choose 1: Students, Faculty & Staff, or ITS only)

Keywords:

(Alternate words that might be searched to reach this article, list should be comma separated.)

Synopsis:

(One sentence describing content of article.)

Review Cycle:
(1-12 months, or a set of specific dates for review yearly)
Content Owner:
(Primary contact, able to review the article on the review cycle.)
Subject Matter Expert:
(Alternate contact, able to review if content owner is not available.)

Article title descriptive of the problem (capitalized as though it were a sentence, not in title case)

Provide a description of the problem in terms of what the reader is doing when the problem occurs (e.g. “You are working on a document in Word. When you save you get an error …”)

Error message

Include the complete error text.

[screen capture of error message]

Cause

Explain why the problem is occurring

Resolution

  1. Step 1.
    [screen capture illustrating step 1]
  2. Step 2.
  • Explanatory note.

More information

Paragraph explaining where more information may be found (with links), or

  • Bulleted list of related articles (with URLs, if possible), and
  • Other resources

HTML

If you are familiar with the basics of HTML (Advanced knowledge is not required), you can use the HTML layout guides to format your content. Be sure to fill out the required data at the top and bottom of the form before submitting your article.

More resources about the ITS Knowledge Base