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Problem with Accessing OneDrive on BCIT-Issued Faculty and Staff Computers

Problem

You login to your BCIT-issued work computer and the OneDrive icon has a slash through it and doesn’t show up in File Explorer. When you click on the OneDrive blue cloud icon in the task bar and try to sign in, the panel just disappears.

Cause

This happens when you have associated your BCIT email address with a personal Microsoft account at some point in the past. The automatic silent config process checks the email address, recognizes that there are two possible accounts to connect to and cannot resolve the problem of deciding which one, so then just fails to properly configure the account and permit access to OneDrive.

To check that this is the cause in your case:

  1. Open an incognito/private window in your browser and go to office365.bcit.ca.
  2. Enter your BCIT email address as the username and click theĀ Next button it prompts you to select a personal or work/school account.
  3. If this is the cause of your problem, you will see a message like the one below asking you to choose between accounts associated with that email address.
    Message saying that this email is used with more than one account from Microsoft
    If you are instead just asked for your BCIT password, this isn’t the cause of our problem. Please contact the service desk.

Solution

A significant part of the solution is to remove your BCIT email address from your personal Microsoft account. This is relatively simple as long as you know the password to your personal Microsoft account.

In your browser:

  1. Go to account.microsoft.com/profile/ and login with your BCIT email address and your personal Microsoft account password (not your regular BCIT password).
    • Note: If you don’t know your password, do a password reset. The email should go to your work email allowing you to reset the password of your personal Microsoft account.
  2. Under the Account info heading, click Sign in preferences.
    • Note: You may be asked to reconfirm that you are the correct account holder at this point, perhaps by getting a code sent to your email address or phone number.
  3. Under the Account alias heading, check whether you already have more than one email address associated with your account.
    • If you have multiple email addresses listed and there’s already one listed that you would want to use as the primary one for your personal Microsoft account, proceed to step 4.
    • Otherwise, if you have only one email address listed:
      1. Click Add email.
      2. Choose whether to create a new outlook.com email address or use an existing personal email address.
        • Note: If using an existing personal email address, it must be one that is not already associated with another Microsoft account.
      3. Type in either your new outlook.com email prefix or your existing personal email address.
      4. Click the Add Alias button. You’ll be taken back to the Manage how you sign in to Microsoft screen and should see the new email address listed.
  4. Click the Make primary link next to the non-BCIT email address that you wish to use.
  5. Log out of the account then log back in using the new alias to confirm that it works.
  6. Return to the Manage how you sign in to Microsoft screen and click the Remove link next to your BCIT email address.

Once your BCIT email address has been removed, try restarting your BCIT-issued computer and re-logging in. Either immediately or after a short delay and another restart, you should be able to access OneDrive normally.

If it’s been more than half an hour since you removed your BCIT email address from your Microsoft account and you’re still experiencing trouble with accessing OneDrive even after a restart, please contact the Service Desk.